How to check crash dump configuration

From Wiki-UX.info
Jump to: navigation, search

How to check crash dump configuration

When a HP-UX system finds an unrecoverable system error, it may generate a Transfer of Control signal (TCO). This signal will force the kernel to release control of the server to the firmware before restarting.

1. When the kernel recieves the TCO, evaluates if the the current content of the memory should be saved according to the SAVECRASH value, 0 equal to NO, 1 equal to YES.

# grep SAVECRASH= /etc/rc.config.d/savecrash
# SAVECRASH=1

2. If the system is configured to save the memory content, it would check where that information would be saved checking for the dump device.

# lvlnboot -v | grep -i dump
Dump: lvol2     on:     /dev/disk/disk12, 0

After all the memory is "dumped" from the volatile Random Access Memory into the dump logical volume (/dev/vg00/lvol2 in most cases), it will return control to the system firmware. The firmware will reboot or shutdown the system.

When the system restarts it will check if it is configured to save the dump information during boot time on /etc/rc.config.d/crashconf according to the CRASHCONFG_ENABLED value, 0 equal to NO, 1 equal to YES.

# grep CRASHCONF_ENABLED= /etc/rc.config.d/crashconf
CRASHCONF_ENABLED=1

If the system is configured to save the crash, will check the SAVECRASH_DIR value, /var/adm/crash by default and move the data from the dump directory into the the configured filesystem.

# grep SAVECRASH_DIR= /etc/rc.config.d/savecrash
SAVECRASH_DIR=/var/adm/crash